Can't seem to put mixer as interface in DAW

Andrei Moraru

Well-known member
Nov 11, 2019
330
700
1,566
andreilucianmoraru.com
Hey guys.

So I have a problem that I did not have before. I have a Behringer Xenyx X1204 mixer and I plugged it in my computer via USB. At first, everything was great and I could record myself in Reaper, no problem.

But now, I can't seem to be able to do it anymore. I can select the mixer as Input Device in Reaper, but for some reason, it sees it as Microphone...and I think that may be the problem, but I don't know how to solve it and it's really annoying.

Any and all help is greatly appreciated.
 

Ed Seith

Well-known member
Nov 11, 2019
1,899
1,271
3,081
49
Marana, AZ USA
I do not have any kind of interface like that, but pretty sure it's not supposed to be an input device - in Reaper it should be added at Options -> Preferences -> Control/OSC/web.

Try that.
 

Andrei Moraru

Well-known member
Nov 11, 2019
330
700
1,566
andreilucianmoraru.com
@Ed Seith Didn't work, sadly. The idea is that I am using the Behringer Mixer to plug my guitar so I can record it in Reaper. The trouble is, while I can see the mixer picking up the input from the guitar, when I try to record something using the plugged in guitar it doesn't work.

It used to work before, but it stopped for...unknown reasons.
 

Ed Seith

Well-known member
Nov 11, 2019
1,899
1,271
3,081
49
Marana, AZ USA
@Ed Seith Didn't work, sadly. The idea is that I am using the Behringer Mixer to plug my guitar so I can record it in Reaper. The trouble is, while I can see the mixer picking up the input from the guitar, when I try to record something using the plugged in guitar it doesn't work.

It used to work before, but it stopped for...unknown reasons.
Okay, I looked up that unit, and it's got preamps built in, so it's kind of a cool device. If it worked before and it stopped, you need to think hard about what has changed about your setup since it worked last. And it may come down to uninstalling and disconnecting the Behringer, rebooting, and then reinstalling it like a new device again, to reset the defaults.
 

Andrei Moraru

Well-known member
Nov 11, 2019
330
700
1,566
andreilucianmoraru.com
@Calvin Phillips and @Ed Seith thanks for the input.

The idea is that the only thing I think noticeably changed was that I've added bluetooth receiver in one of my USB ports. Other than that, nothing has changed. I did run into this issue last time I attempted to record, but it somehow got fixed. Just gotta figure out the somehow.

I'll try reinstalling the drivers, though when it worked the first time, I didn't even need to install anything other than what was installed when I plugged the mixer in. Very very weird.
 

Ed Seith

Well-known member
Nov 11, 2019
1,899
1,271
3,081
49
Marana, AZ USA
Under Audio System in Reaper you REALLY should be using ASIO if you can get it working with the Behringer. MUCH lower latency connection and more reliable. Also just try disabling Bluetooth for a moment and see if the problem self-corrects. If it does, you may have found your culprit.
 

Calvin Phillips

Well-known member
Nov 11, 2019
2,015
980
2,096
cambridge ontario
www.reverbnation.com
What I would try to do is I would right click on Line In (Behringer...) and I would set it as a default device and then I would try to record something.
I think the computer recognizes both as default unless you disable one. And since hes using the bluetooth for his speakers the PC will automatically assume he wants it for his mic too. Or atleast that's how my PC reacts to my camera.

By disabling it you take away the pics ability to even think about it. Past that I'd suggest reinstalling everything again. Although it's probably just gonna take you in a circle.
 

Andrei Moraru

Well-known member
Nov 11, 2019
330
700
1,566
andreilucianmoraru.com
@Ed Seith , @Calvin Phillips and @Filip Tomiša I have managed to get it to work. I remembered from long days past a solution that helped me out of this pickle. I basically connected one of the mixer outputs to my computer line-in port. And it got the thingamajig going because I can select the Computer Line In option now, which is not in conflict with anything else.

Thanks so much for your help, I fear I would have spent days on this with no avail :D.
 
  • Like
Reactions: Filip Tomiša